RE: Probleme mit Multisite Installation und Cross-Domain Cookie

Hallo Zusammen,

Wir haben folgende Konstellation einer Multisite-Installation:

https://subdomain.domain.de (Hauptseite)
https://subdomain.domain.de/unterseite1
https://subdomain.domain.de/unterseite2
https://subdomain.domain.de/unterseite3

Nun haben wir auf allen 4 Webseiten (WordPress Multisiteinstallation) Borlabs installiert und alles funktioniert auch soweit.

Allerdings wird auf der Hauptseite (also https://subdomain.domain.de ) Das Cookie-Popup immer wieder von neuem abgefragt, Das Cookie wird aber erfolgreich im Browser gesetzt (laut Devtools). Trotzdem kommt die Abfrage bei jedem Seiten-Refresh.

Außerdem wollten wir die Möglichkeit des Cross-Domain-Cookies benutzen. Mit den Einstellungen wie hier( https://borlabs.io/kb/set-up-cross-domain-cookie/ ) beschrieben funktioniert es leider nicht, und man muss trotzdem bei jeder Webseite ein eigenes Cookie-Popup bestätigen.

Der Fehler auf der Hauptseite tritt nur dann auf, wenn Cross-Domain Cookies eingetragen sind. Es liegt also irgendwie an diesen Einstellungen.

Kann mir einer sagen auf was man achten muss damit dieser Fehler nicht auftritt und Cross-Domain Cookies richtig gesetzt werden?

Tobboo Neues Mitglied Gefragt vor am September 27, 2021 in Borlabs Cookie.
Kommentar hinzufügen
9 Antworten

Nachtrag: eventuell reicht es, den Pfad überall auf / zu ändern.

Hilfreiches Mitglied Beantwortet vor am September 28, 2021.
Kommentar hinzufügen

Deine Antwort

Mit dem Absenden deiner Antwort erklärst du dich mit den Datenschutzbestimmungen und den Nutzungsbedingungen einverstanden.