RE: Skript-Blocker für Elementor Widgets werden geladen aber dann nicht ausgeführt

Ich bekomm es einfach nicht hin, dass ein Skript-Blocker wieder den Code in dem freigegebenen Skript korrekt ausführt. Ich hab einen einfachen Test mit einem Widget gemacht, wo ich nur will, dass die folgenden 3 console.log Ausgaben erscheinen:

script.js:

jQuery( window ).on( 'elementor/frontend/init', () => {

    console.log( '2. elementor/frontend/init Elementor geladen' );

    const addHandler = ($element) => {

        console.log( '3. frontend/element_ready/example.default, addHandler' );

        elementorFrontend.elementsHandler.addHandler( Example, {
            $element,
        } );
    };
    elementorFrontend.hooks.addAction( 'frontend/element_ready/example.default', addHandler );
} );

console.log( '1. script.js geladen' );

 

Das script.js wird geblockt und nicht geladen, was es ja soll. Aber beim Entsperren erscheint immer nur die 1.) console.log Ausgabe, dass das script.js jetzt geladen wurde – aber der restliche Code wird nie ausgeführt. Auch nicht, wenn ich die Seite danach neu lade, oder die Einstellung benutze, dass die Seite nach der Einwilligung neu geladen werden soll.

Ich bin für jegliche Vorschläge dankbar!

bwell Neues Mitglied Gefragt vor am Juli 30, 2021 in Borlabs Cookie.
Kommentar hinzufügen
5 Antworten

Bitte frage bei Elementor nach, wir können dir nichts zu deren JavaScript sagen, das ist kein Code von uns und der Code ist umfangreich, dass wir uns da „nicht mal eben“ einlesen können.

Hilfreiches Mitglied Beantwortet vor am August 2, 2021.
Kommentar hinzufügen

Deine Antwort

Mit dem Absenden deiner Antwort erklärst du dich mit den Datenschutzbestimmungen und den Nutzungsbedingungen einverstanden.